Delayed Google Workspace integration completion
Incident Report for Push Security
Resolved
This incident has been resolved.
Posted Mar 25, 2023 - 07:41 UTC
Monitoring
We’re investigating an issue where new Google Workspace integrations are taking longer than normal to complete. Integrations experiencing this issue will eventually finish, though it may take as long as a few hours.

This issue does not affect existing Google integrations.

After investigating thoroughly on our side, we believe the issue may be related to a service degradation for Google OAuth APIs.
There is currently no workaround for this issue, and we will continue monitoring over the weekend.
Posted Mar 24, 2023 - 18:35 UTC
This incident affected: Other (Google Cloud Platform Identity & Access Management).