Webhook event processing delays

Incident Report for Push Security

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 16:54 UTC

Monitoring

The backlog is steadily being cleared, and all remaining events are expected to be delivered within the next few hours.
Posted Aug 14, 2025 - 15:33 UTC

Identified

Our data processing infrastructure is currently experiencing delays, which is impacting the timely delivery of certain events over Webhooks. Detection events are still being delivered immediately. No data will be lost once recovery has taken place.
Posted Aug 14, 2025 - 09:02 UTC
This incident affected: Webhooks.